Error While Writing to File

Hi, I have just hit a issue where I’m constantly get the pop-up error message:-
“Error writing to file C:\Comic Collector.…[etc]
This is probably caused by a diskspace problem.
Chose “File / Save File As” from the menu to save the data to a different location”
I have done this, still got the same message so saved it to an external drive, same message again so uninstalled / re-installed Comic Collector but the same error message is appearing when ever I try to edit a comic or close Comics Collector.
Can any one advise on how I can resolve this issue.

Hi @prhough sorry to hear you’re having some troubles with Comic Collector.

The error can mean a problem with the HDD, or SSD. Bad sector. I’ve seen that before. We can try this:

  1. Can you shut down the program, then, as a test, rename the Documents > Comic Collector folder to
    “Comic Collector 2”

  2. Now duplicate that folder (ctrl+c and then ctrl+v)

  3. The folder that gets created, rename it to “Comic Collector”
    (so you now have Comic Collector and Comic Collector 2)

  4. Now, reinstall the software from

Does it work now?


Many thanks for your quick reply, I did follow your instructions but I still got the same error. However I then tried the copy I had already created on my external drive, changing the Folders in the options to point to the new location on the external drive, then loaded the back-up from the previous day which I expected to be OK and synced with CLZ Cloud to download the few changes I had made since that back-up. This worked and there is no more pop-up error messages, although I need to reenter the information on the Details / Content tab for the last Comic I had updated. I don’t think information on this tab syncs with the cloud. In hindsight I realise that downloading the back-up file after using the your method of copying the Comic Collector folder may have also worked and would have meant that I wouldn’t need to change the folder locations in the options.
I have now moved the folder back to the original location, again correcting the folders in the options to point to the correct location and Comic Collector still works fine. I still have the original folder, which had been named ‘Comic Collector 2’, which I’m reluctant to delete so that may stay on there a while.

Many thanks once again for you help, it is greatly appreciated.
Paul Hough

I’m happy to see that you got there in the end. Yeah keep the folder for a little while.

Content indeed does not sync with CLZ Cloud by the way.

When using an external drive, make sure it is always on and always available to Comic Collector because the moment it is not during start up, the program will reset all folder paths to a standard Documents folder.

I am now getting this same error - but with Movie Collector. I’m a bit confused as to the solution. I don’t want to try it if there’s a chance of doing it wrong and losing all my data. After the error, everything saves as normal - just the recurring message appears. When I check my Cloud data, it’s all there. The error does not seem to prevent anything from being saved. Should I proceed with this same solution?
Thank you

Your problem might be completely different.

What is the exact error, and when exactly does it appear?

Can you try opening the program “As an admin” via right click menu?

On saving new movies I get that error (same as the post I read above - “Error writing to file C:\Comic Collector.…[etc]
This is probably caused by a diskspace problem”)

When I closed Movie Collector I received another error - "Access violation at address 00000000000410625 in module “MovieCollector.exe”, Read of addressFFFFFFFFFFFFE0.

I may not have exactly counted the zeros and F’s correctly.

I restarted my PC (Wndows 10) and now Movie Collector does not run. I made a copy of the Movie Collector folder. Should I reinstall the program? I have run a check of the drive and it shows no errors. I have also saved a snapshot of the errors, but I don’t see an option her to send it.

Thank you,


Resolved - tried again to open the database and it offered to allow me to revert to a recently saved version. I did that and then did a sync with the cloud, then saved it as a new version.

If you see where I have done something to cause this issue, please let me know,

I’m not seeing anything in particular that might’ve been done wrong, if it works now, that’s good.

If the problem returns, please feel free to create a separate topic about it.

That said, (I will always say that on these types of strange errors), have you considered switching to Comic Connect at all? These kinds of computer / rights errors will not happen there.

Comic Connect is easier to use and easier to manage, while still giving you all features and customization options.
Also the Connect web-based software is what all our development and support is focused on.

If you switch to Comic Connect with our Trade-In offer, we will trade-in your remaining Comic Collector subscription days and will transfer them to the Connect edition, plus we will add 4 extra months for free.

Full details about the advantages of Comic Connect, and our Trade-In Offer can be found here:

Let me know if you are interested or have any questions about switching to Connect.

Thank you very much for that suggestion. Just to clarify - I use Movie Collector, not Comic Collector on my PC. I just ‘pasted’ the error from another post about Comic Collector because it exactly matched what I was getting in Movie Collector.

Is that option offered for Movie Collector also? I just may consider it if all features are still available. I have several custom fields I wouldn’t want to lose if I switch over.

Great software!

Thank you

Ah, yes. This topic was posted in the Comic Collector forum, but indeed, yes, this is also available for Movie Collector users.

Full details about the advantages of Movie Connect, and our Trade-In Offer can be found here:

But, right now, User Defined Fields are not supported in Connect. I don’t know if you use those?