Permission denied when trying to print (can't create the *.xls files)

This morning I tried to print a list of the duplicate comics I have.
Found the “How to Print” instructions in the online doc, and followed their instructions. (Printing a Simple List - Comic Collector for Windows - V19)
Ran into some permissions errors and can’t print. :frowning:

What “user” does Comic Collector run under so I can give the user modify permissions over the “C:\Program Files (x86)\\Comic Collector\Templates” directory?
Or is there another fix?

In case it helps here are the steps I took, and the errors and fixes I did along the way.

  1. Sorted my list as desired.
  2. Selected the comics I wanted to print.
  3. Clicked “File” → “Print”.
  • Got an Access Denied error message for file “print_item_customlist.xsl”. (basically pic 1)
  1. I copied file “print_item_list.xsl” and renamed it to “print_item_customlist.xsl”.
  • Had to provide Administrator permissions to do this. (basically Pic 2 and 3)
  1. Close the Print window and repeat step 3, and the Print window opened, w/out error.
  2. Selected the options I wanted.
  3. Clicked the “Save As Template” button.
  4. Left all the fields as default. (Pic 4)
  • (Filename: print_item_mylist.xsl, Description: My Template, Overwrite checkbox: checked)
  • BTW the header labels having a background color of white with the grey text (default theme the install gave me) makes reading the header labels REAL hard. (Pic 4)
  1. Clicking Save gives Access Denied error for file “print_item_mylist.xsl”. (Same basic message as step 3.) (Pic 1)
  2. Repeated same process as step 4, but renamed file to “print_item_mylist.xsl”.
  3. Repeat steps 7, 8, 9, same Access Denied error.
  • Even tried unchecking the “Overwrite” option.
  1. Fine, I don’t need to save the template, I’ll just print.
  2. Clicked “Print Preview”, and got a warning not everything would print with the preview and to use “Print” instead.
  3. Clicked “OK”, then got the Access Denied popup for file “print_item_customlist.xsl”.
  4. Clicked “OK”, then clicked “Print”, same Access Denied popup.
  5. Clicked “OK”, and the Print window closes along with the error popup.

I can print. :frowning: :sob:

Pic 1:

Pic 2:

Pic 3:

Pic 4:

After posting I think, “HEY! Maybe the Troubleshooting - Comic Collector for Windows - V19 page might have some things to try!” :smiley:

Sadly none of the processes there seam to apply. :frowning: :sob:

System Error. Code: 5. Access is denied - Comic Collector for Windows - V19 looked close, but not quite the same issue.

Can you try running the program “as an admin” via right mouse click on the shortcut, and then see if it works?

That allows me to print w/out issue. :smiley:
Right now I’m getting blank rows (cover art is only thing showing up), but I think that is because of me trying to fix things, and I know how to undo those fixes and try more.

Thank you @CLZ_AJ, I’m gonna blame that I did not think of trying that on the fact I was only 1/2 way through my first cup of coffee of the day.

— EDIT —
Tried undoing my fixes, and still getting blank rows (pic below). I’m also working, so have only tried making things work for about 60 seconds. Will try more tonight, but incase you had any insight figured I’d post an update.

Do you have your font color set to white? It kinda looks like that is what happening here…

Check your print settings, then look for the font color.

Good call!
The font was set to white.

1 Like