"Saving Movie" takes ages/doesn't work

Is anybody else having an issue? I edit a piece of information in Movies Connect and then click save but it stays on “Saving Movie” for ages, sometimes doesn’t even save at all.

Seems to have this issue no matter what browser I use.

Hi @Foxcek,
we do not have any other reports on saving taking ages.

Here’s a video where I try to edit something in my Movie Connect:

Could it be that you have some sort of plugin or VPN in your browser?

Which browsers did you try?
Can you try in “incognito mode”?

I noticed you’ve emailed in as well, but I’ll keep the conversation here for now.

Thank you very much. I tried it in Incognito mode and it still would not save no matter what I do (which is weird because CLZ Comics works just fine).

Tried it on another computer and it works so it’s definitely something with my laptop, perhaps VPN or something as you suggested.

If you have a VPN indeed, try disabling it, to see if that does anything?

You are able to normally browse around your collection?

Do you remember when this problem started (or was it always there?)