Scanner recognizes book but book collector does not

if I scan in 9780061052422, scanner finds Foundation and Chaos by Greg Bear, but when I go into Book Collector, it is unrecognized and if I type in the ISBN its still not found. Where is the scanner getting its information? AND why is not in the core.

@KenHunter can you please try again?

I’ve just scanned it into Book Collector and it seems to have found and added the book you said.

If it doesn’t work can you post some screenshots?

Ok it did work that time. I sometimes get the error when I scan with my phone but don’t have the add screen up. I can type in the IBSN and it finds it. Don’t know why that wouldn’t work this time.

Also, when I get books that don’t show up in book collector correctly but are in the scanner correctly, I can delete them from the add screen but can’t figure out how to make them sync again with the scanner. Only thing I could do was delete them from the scanner and rescan them. Am I missing something.

I’m sorry to say I don’t quite understand this process. Is there a step-by-step you can lay out for me that I can follow to get the same problem?


I opened Book Collector but not the Add Books screen.
I opened the scanner app on my android phone and scanned 9 books.
The scanner recognized all of them.
I then opened the Add Books screen and selected the ISBN tab.
After a few moments the tab synced with the app.
The first five books were not found but the last four were recognized as the correct titles.

Example the first book was ISBN 9780312861872.
If I type in the ISBN and search is does not find it
However if I type in the author/title, Orson Scott Card Xenocide, it comes back in the list with an entry for that ISBN.

If I clear everything out of the add books screen and the scanner and then open the add books and scan one of the books it will show correctly.

My best guess is the scanner is syncing the list of ISBN so fast that the program doesn’t have a enough time to find them,

Thanks for your reply.

When the “ISBNs” sync from CLZ Scanner to Book Collector’s ISBN queue, it just sends the ISBN.

Book Collector then performs searches to find the matches (again). CLZ Scanner does not “send the author/title” to Book Collector’s ISBN queue.

I’ve just tried this:

  • Had Book Collector open

  • Had CLZ Scanner open and scanned 10 ISBNs here. All were found by the way.

  • Opened Book Collectors “Add Books” screen on the ISBN tab, and waited for the sync to finish.

  • All ISBNs showed, and all of them immediately found book data.

  • I also typed in the 9780312861872 ISBN, which also found a book.

So I’m currently not able to reproduce this problem.

What’s next?

  1. If this happens again for you, can you close the Add Books screen, and restart it, to see if it then finds the books?

  2. If it happens again, can you make a full size screenshot of both your Add Books screen, and your CLZ Scanner barcode queue so I can see the issue at hand?

  3. Also, can you leave the queue as is, so do not add the books or remove the ISBNs - and just post here, that way we can check your queue on our side to see what’s going on.