Sync Issue: Missing Covers

Last night I performed a sync from my desktop software to my cell phone application.

When the sync was completed, it appears some of the cover images never updated (see attached image).

How can I correct this so cover images are available?

  • Chad

Are you on iOS or Android?
Also, which version of the app?

I am asking because the above sounds like a problem we fixed last week:

Android v9.0.3

I am sorry to hear you are having problems with the images in your CLZ app.

First, I still see all your images in your CLZ Cloud, so that’s good news!

Here’s how to resolve the problem on your app.

  1. FIRST: Please open the Settings app on your Android device and navigate to the app list. Select the CLZ app and make sure the ‘storage’ permission is toggled ON.

  2. THEN from the menu in your CLZ app, sync with CLZ Cloud to make sure all entries are up in your CLZ Cloud.

  3. Now, open the menu, tap Maintenance and then “Clear Database”.

  4. Finally sync with CLZ Cloud to download the data and images again from the CLZ Cloud

Can you please let me know if that worked or not?

I seem to be having the same issue after I got a new Android phone (CLZ Comics v 9.2.1) and did a successful sync. I can see my covers on desktop app Comic Collector 23.7.3 and the covers on my old Android phone.

Is the solution from @CLZ_AJ CLZ_AJ the way to go? Has this solution worked for @MrWizard?

I’ve been going through each comic title, selecting the issues missing covers, and doing an update from Core. This of course is very time consuming and since I have a very large collection, this will take a lot of time. I also don’t want to clear the database and sync again as this took several hours the first time I did it and I had to keep checking because the sync would freeze and I’d have to cancel, or close the app and sync again. The sync seemed to continue from where it left off, but having to babysit the whole process isn’t the way it should work.

Thanks.

@Kuya3stan , your problem might be a the same indeed.

If you are in sync right now, then I would advise for you to follow the same steps.

For your information, I see 33.425 comics in your CLZ Cloud, if that number is correct, you can follow the same steps. This will also take some time (a lot of comics to sync) but it is most likely the solution for you too, indeed.

@CLZ_AJ my sync has finally finished and the suggested fix did not work. The sync was the same as the first time I tried. It stopped several times and needed to be restarted until it finally finished.


Did you do this step?

Also: how much free space is on your device?

I don’t see a toggle permission for storage. I see “Storage and cache” and if I choose that my only choices are to clear storage and/or clear cache. I have 61.96 GB of free space, so that’s not the issue.


What happens if you tap on “Permissions” ?

@CLZ_AJ I don’t have any permissions that are denied.

Maybe that’s an older version of Android that has the toggle? Neither my new phone nor my old phone have the toggle. They both have similar screens as the screen shots I’ve provided.

@CLZ_AJ is there anything else I can try?

I have asked a developer to look into this when he arrives in the office today.

If you go to the “All Comics” folder, it is possible to tap and hold on a comic, then “select all” and then use Update from Core to just download the covers from Core. That might be the best route here for now.

@CLZ_AJ, I gave this a try a little while back, but didn’t get a chance to check out the results until recently. For the most part it seemed to have worked. I found a couple of weird ones where only partial covers were downloaded and if I tried to update them again the message I get is “No updates found”. There were a few others where the covers are still missing and when I try to update them I get the message “No updates found 1 skipped (not linked to core)”. These are all comics that display properly on my old phone. There aren’t that many so I’ll probably delete the comics and add them back. Hopefully that fixes things.


Thanks for your help!

Good to hear that worked! (for the most part)

For that JSA Classified #34 one, that is indeed strange. Can you edit that comic, remove the cover, save it, and just update that one, to see if it downloads the cover?

1 Like

@CLZ_AJ , ok that worked for the 2 comics I found that were showing partial covers! I tried to do the same for the comics missing covers but I don’t get the option to delete the cover. It looks like for those comics I’ll have to delete the issue and add them back. Thanks for your help! I’m glad there aren’t too many and I hope I don’t find many more as I keep using the CLZ Comics app.

1 Like