Synch Issue

Good evening,

I have noticed when editing the Sort Name field (from the Manage Pick List selection) that after editing multiple entries (Cast or Crew) that it Synchs - Uploads - with Cloud fine. The problem is that there is some entries that suddenly appear in the Download from Cloud thereby erasing the Sort Name change I made. I have to go through and find the entry, re-edit, and synch again. This can happen many times before the entries do not want to be downloaded to app again.

For example: I edited 1 entry in the Musician Sort Name field. This had 18 entries in the app. I uploaded to cloud and all synched well. Automatically, there were 11 entries to be downloaded from the cloud. Once I synched, the Sort Name reverted. Each attempt same results - 18 upload and the exact same downloaded. It took 5 times before it was successful. There is one current Actor Sort Name I caannot get to upload without getting the download result.

The only way i have never had an issue was when there was 1 Sort Name change and only 1 entry to be changed. After experimening, I had the same issue with 1 Sort Name change and 2 entries.

Also, it does not always happen. Sometimes I can have many Sort Name changes and it uploads with no download returns.

Just an observation

I don’t feel this is just an observation :slight_smile: it sounds like a scary bug.

You’re actually saying you made changes locally to a movie,
Synced UP to CLZ Cloud.

Then, you had syncs that wanted to come down after that, while you didn’t change anything on any other device?

I would love to be able to reproduce this, because if you just make changes locally, then sync up, you should not get downsyncs.

Is there any sure-fire-way I can make this happen on my CLZ Movies for an item?

I have had this going on for a bit. I wanted to ask why I have Downloads when i have not made changes anywhere else. I never gave it much thought as a problem until now.

After experimenting I figured out it was Uploading but then partially returning (so to speak) items to be downloaded. As I mentioned, it works fine when there is 1 Sort Name edited and only 1 entry.

Strange thing I noticed: in my example I Upload 1 Musician with 18 entries. I get 11 Downloads back. They were part of the 18 I uploaded.

The odd thing is that when I synch the changes again, its the same 18. I havent programmed or coded in years, but I thought it would have picked up at the 11 that were Downloaded and not started with thecm original 18 again. That may be normal though.

Perhaps if I run through a cycle with two screen records and send them.

I can do the one Actor I cannot get to change.

Further troubleshooting found that there are miscellaneous Front Covets or Back Covers being Uploaded. This is from the Manage Pick List then when I select a Field to edit.

It only happens with Covers. No other field or entries Upload. Keep in mind, this is random and no changes to any covers have been made.

I can find no reason why random Front or Back covers are being Uploaded. There is no readily apparent reason for the covers. Sometimes its only a Front or only a Back or both. Many times its none and only the Field I edit Uploads.

If a cover Uploads, that is when I receive a Download in App and it erases the Field change to its prior state.

That’s what I have definitely uncovered thus far.

Update : The Upload Front and/or Cover is always a cover of one of the Field I change in that moment.
It then Downloads in App and as I said, erases the change(s) I made to that Field.

If you change a cover from standerd to “custom” (your own cover), then a downsync change can happen - but that should not change other fields of course.

If you do not change the front/back cover, are you able to reproduce it?
Or if you do this for a movie that does not have a custom cover, can you reproduce it then?

Ive done some more checkng. It happens whether the Covers are Custom or Not.

I have also edited the Extra field with the same results although I could not determine if any of my edits in the Extra field were turned back.

Could you make a video for me where you

  • are currently in sync (show this by opening the sync screen)
  • make 1 edit as you did
  • then sync and make it show the change is going up, but that more syncs are coming down on the next sync?

Here’s how you can make a screen recording on your Android device:

  1. Swipe down twice from the top of your screen.
  2. Tap “Screen record”.

If “Screen record” is not there, you might need to swipe right to find it. If it’s not there, tap “Edit” and drag “Screen record” to your Quick Settings.

  1. Choose what you want to record and tap Start. The recording begins after the countdown.
  2. To stop recording, swipe down from the top of the screen and tap the “Screen recorder” notification.

You can find the files in the Photos app in Library > Movies.
You can send me the file(s) via:

(or attach here, but it might be too big)

Thanks, I’ve seen the video, and I will look it over with our developer here. It will take some time to get back to you though, my apologies for this delay.

Thanks for pointing this out, we’ll be in touch!

Thank you much.

Hi @JUnderwood, we’ve been trying here, but we are not able to reproduce the issue you’re having where we change the actor, and it indeed does upsyncs for all movies this actor is in, but it never gives us a downsync.

I’m not sure what else we can try here right now or if there’s anything we’re missing when we try to reproduce from your video.

If you do this with an actor who is only part of movies that do NOT have a custom cover, is this also happening?

Thanks for the diligence.
I have tried many configurations. Actor, Musician, Director etc… and with /without custom images. It happens when I update 1 or several of the selected fields. (Actor, Director etc…)
I noticed that when there is only a single item to update, IF it comes back with a Cover Update, it does NOT change the fueld I updated. When there us 2 or more items to be updated, then it more often than not reverts back and i have to redit.

Much thanks and appreciation

(I also am working on another weird issue. When I add extras, they add perfectly at first, but I check later and its only partially there. The entry is cut off mid sentence or mid word. I have only began looking into this.)

Alright, I hope we can, in the end, find this bug still, because it is quite annoying of course.

As for the extras bug, if you do find it, feel free to just directly contact me through our regular support email - or drop us another video at least so we can see it happening (that always helps a lot!)