V23.3.5 Access Violation

This error occurred 1 time yesterday but has occurred 2 times today. I try to save my changes (which were minor) and get the access violation error. I attempted to do a ‘Save As’ on 2 different volumes and got the same error. All volumes have more than enough adequate storage space so that isn’t the cause. Yesterday’s event resulted in having to restore a previous backup, but it doesn’t appear anything was corrupted by today’s error.
MCLZ - 1 Error writing to file
MCLZ - 1 Error writing to file
MCLZ - 3 Refuses to Save As on different volume
MCLZ - 4 Refuses to Save As on different volume
MCLZ - 5 Access Violation

I also got this error today accompanied with the access violation, and have seen it in the past.


Seems to happen randomly when editing several movie title’s episodes and then using the fwd / back arrows to navigate between them.

Thanks for the feedback. That seems logical as I was placing a check mark in the audio section and navigating to the next season using the fwd/back arrows. I think I’ll try closing each season record first and manually select the next season and hopefully it will resolve the access violation error.

I have steps to try and prevent the diskspace error, but I’m not sure if it will solve your problems.

That said: @roybo I would advise for you to use File > Save Database As and save it to Documents > Movie Collector - as it seems you are running from your automated Backup folder, and that is generally not a good idea.

As for @aemurray you also have your .mvc saved in a strange folder that I would not recommend.

Could you also try using Save Database As, and save in Documents > Movie Collector?

Then, are you always able to reproduce this clicking next/previous? Or just randomly sometimes?

Ok I saved as you suggested. This error pops up randomly. Let you know if it happens again.

I do believe your troubleshooting appears to be valid as on the three occasions the error I occurred I had been making a minor change to several seasons of Stargate SG-1 (simply placing a check mark in specific audio format) and using the FWD/BCK navigation buttons.

I believe the database naming/storage location is irrelevant to this error as my configuration has been in place since April 2006 without incident. And the violation hasn’t happened frequently. As for now, I will change my navigation habits by not using the FWD/BCK buttons and see if that makes a difference.

@aemurray @CLZ_AJ Without a doubt it has something to do with the FWD/BCK buttons being used in conjunction with editing (Certain Fields?) multiple entries that locks it up. “Disc Space” seems to be a misnomer as I have Terabytes of available disc space. And as I noted this is not new and has happened to me multiple times in the past several months if not longer. Maybe since the last update???

Never realized that this was the wrong space for the .mvc Db and believe that I may have moved it there inadvertently while undertaking a recovery years ago. I’ve relocated it this morning as prescribed, but I’m with @aemurray and doubt that the physical location has anything to do with it. A folder is a folder.

However, going forward I will document and note any apparent causes and revisit them here if the error persists.

Well, historically seen, the Disk Space error came when people had bad sectors on their HDD, but that is a long time ago. Our old (internal) help files that we use for the desktop software has one mention of Disk Space error, and instructions to duplicate the Movie Collector folder, so it will occupy a different sector on the HDD, and without fail this had always worked.

That said I do think there might be some timing issues using next/previous that might throw this misnomer error - but very hard to reproduce as we think it might be a timing issue in combination with certain fields. Very hard to reproduce/catch.

If you are able to reproduce it consistently with a certain field/click combination, and I can reproduce it too, we can probably find the problem pretty quickly.

Thanks, AJ will let you know if it reoccurs

Just something to add, we’ve seen cases where Dropbox, OneDrive, stuff like that, holding our .mvc database file “hostage”, where save problems can occur.

When you hit “next” a lot, on each “next” click, it will do a “save”, and if your trusty backup program decides to “pause” the file to make a backup, our program can’t save, and this error can occur.

Might be something to give a look as well.

Appreciate the feedback and troubleshooting. I will keep a watchful eye for any error event. By the way, only one record (a season I had just made a single edit to before FWD to next season using the buttons) was corrupt and lost. I had a current backup restored which alleviated the problem. No data appears to have been compromised during the 2nd and 3rd event.