Default instrument not being retained in pick list

When using the “Manage Pick Lists” feature to update musicians, I enter a default instrument, but it isn’t always retained. I recently updated several musicians using the Manage feature, then returned to those musicians but the instrument field was blank. Strange, but if I re-enter it, it seems to stick the second time.

That is strange indeed.
Do you have an idea what action in the app caused it to disappear?

I’m not sure it “disappeared,” I think it never saved. Here are the steps: I selected Manage Pick Lists, selected Musicians, selected a musician, typed in a default instrument, selected “Done,” then opened the next musician and repeated the process. I did this for several musicians in a row, then selected the left arrow at the top to exit the pick list. Later I opened the pick list again to update a few more musicians and realized that the ones I’d done earlier were blank. I updated them a second time, then came back to check and they were correct with the instruments there.

I’ve tried opening Manage Pick List here on my iPhone, put in a couple “defaults”, and went out of the screen. Then back into the screen and the defaults were still there.

Are you also on an iPhone?
Are you able to reproduce the problem at all?

I’m using either an iPad Pro or an iPad Mini, both less than two years old running iPadOS 17.2. There’s an upgrade that was just released, 17.3, I’ll update and try again tomorrow (I’m US west coast, GMT -8) and see if I’m still getting the same results.

I updated to iPadOS 17.3 and the problem persists. Today I opened Manage Picklists, selected Musician, selected Art Blakey, typed in “drums” in the default instrument field, then hit Done. I then selected the next musician (Art Taylor), added the default instrument, selected Done. I then went back to Art Blakey and the instrument field was blank, and the same for Art Taylor. Interestingly after adding the instruments, the musicians moved to the top of the list, no longer in alphabetical order.

The behavior is very strange indeed. I can add an instrument in pick lists, exit the pick list, then come back and the instrument is there. If I do two in a row, then the instrument disappears. If I add one, exit, return, add an instrument to a second musician, then exit, the instrument for the first musician is gone again.

@antonmb I see.

Can you tell me:
Do you open the Manage Pick List screen from the menu top left in the main screen?

Or do you open it through Edit Album, go to musicians, and do it there?

From the top left menu.

I’ve tried your steps but I’m unable to reproduce the problem still.

I would like to see this in a video if you can make it happen for me? Here’s how you can make a screen recording on your iOs device:

  1. Go to Settings > Control Center, then tap + next to Screen Recording.
  2. Open Control Center (swipe down), tap the “Record” button, then wait for the three-second countdown.
  3. To stop recording, tap the red status bar at the top of the screen, then tap “Stop”.

You can send me the file(s) via:

(or post it here)

Thanks for sending the file @antonmb

I was able to reproduce the problem this time, and have reported it to the developers for fixing. Thanks for sticking with me on this one!

1 Like