Musician default instrument not being added

When adding a musician under People in the iOS app, the default instrument is not automatically added the way it is in Connect. Add a musician without typing in an instrument and the instrument will be blank, but add the same musician in Connect and the default instrument will show up.


I’m unable to reproduce this.

Can you open Manage Pick Lists on your iOS app, then go to Musicians, and check that musician to see if the default instrument is actually there?

Here’s a video where I’m trying this:

It is a rather strange anomaly. If I edit an album, select the musician from the drop-down list and add, the instrument will not show up. If I do the same thing in Connect, the instrument will be there (all musicians show instruments in Connect). If I then go back to CLZ, I can now add that musician again in other places and the instrument will show up. Here’s a screen capture video. I’m using an iPad.

Thanks for the video.

On iPad, can you open the menu top left, go to Manage Pick Lists, and then to Musicians and tap on that musician there, to see if a default instrument has indeed been set?

I’ve tried it yesterday and I did notice the default instrument synced, but it may not have synced in the past so you might have musicians without default instruments on your iPad.

There is no default instrument showing on the iPad, or on my iPhone either. I think I reported this issue before, that default instruments added on the iPad weren’t always maintained. Default instruments are all present in Connect though.

Hmhm, Would you be willing to do a full downsync from Cloud to your iPad, (so clear the iPad, then sync from Cloud to iPad), to test if the default instruments all come with? (that is happening for me, so I think that might solve this)

Yes, I can try that. What’s the best way to do it?
By the way, I have two iPads and an iPhone, and the problem exists on all 3 devices. Maybe there’s a bug in the iOS sync?

I’m thinking there was a bug in syncing instruments in the past, but not anymore.

Try on iPad, and only one iPad only… to do this:

First: make sure everything is 100 percent in sync. So sync on all your devices until nothing is there to sync.

Disable autosync.

Then, on one of the iPads, do this:

  1. Tap the top left side menu icon to open the side menu.
  2. Tap “Maintenance” and then tap “Clear Database”.
  3. Tap the top left side menu icon again to open the side menu.
  4. Tap “Sync with CLZ Cloud” and sync your entire collection from CLZ Cloud down to your mobile device.

Now on that iPad, go into Manage Pick List, and check a couple artists (tap on them) to see if the default instrument was synced down!

Ok, I’ll report later. 3200 albums on a slow connection is taking some time.

@CLZ_Alwin I completed the complete database sync and unfortunately the default instruments are still not there.

This is interesting: I created a test album in Connect and added the musician (Wynton Kelly) with the default instrument that shows in Connect. Then I synced CLZ, et voilà, the instrument showed up not just in the album, but also in the pick list! Quite strange.

Checking again a few hours later and the instrument is not on my phone, and it’s now gone again on the iPad.

Thanks for trying this. I’ll run a full test with your data to see if I can reproduce the problem in the office as there must be something wrong in the sync code.

“Checking again a few hours later and the instrument is not on my phone, and it’s now gone again on the iPad.”

That is also quite strange indeed.

I’ll report back here when I know more.

I was able to reproduce the problem with your database and have reported it with our team. I’m afraid I don’t have a quick workaround or fix for this other than to carefully look and enter the instruments as you add musicians - or to just only add them on Music Connect, and not on iPad/iPhone.

It might be some time before we can fix this, but I will post back here when we do.

My apologies for the inconvenience caused!

Thanks, glad you’re able to see the issue. Happy hunting.